.TH BOUNCE 8 .ad .fi .SH "نام (NAME)" bounce \- گزارش‌های وضعیت تحویل در Postfix .SH "خلاصه دستور (SYNOPSIS)" .na .nf \fBbounce\fR [generic Postfix daemon options] .SH "توضیحات (DESCRIPTION)" .ad .fi دیمن \fBbounce\fR(8) فایل‌های گزارش وضعیت تحویل را به ازای هر پیام نگهداری می‌کند. نام هر فایل گزارش برگرفته از فایل صف متناظر با آن است، و در زیردایرکتوری‌ای از صف نگهداری می‌شود که نام آن با توجه به نام سرویس در فایل \fBmaster.cf\fR (یکی از \fBbounce\fR، \fBdefer\fR یا \fBtrace\fR) تعیین شده است. این برنامه انتظار دارد که از طریق مدیر فرایند \fBmaster\fR(8) اجرا شود. دیمن \fBbounce\fR(8) دو نوع درخواست سرویس را پردازش می‌کند: .IP \(bu افزودن رکورد وضعیت تحویل (یا عدم تحویل) به یک گیرنده به فایل گزارش هر پیام. .IP \(bu قرار دادن پیام اعلان وضعیت تحویل در صف، به همراه یک نسخه از فایل گزارش آن پیام و پیام متناظر. هنگامی که پیام اعلان وضعیت تحویل با موفقیت در صف قرار گرفت، فایل گزارش آن پیام حذف می‌شود. .PP این نرم‌افزار نهایت تلاش خود را برای ارسال اعلان به کار می‌گیرد. حتی در صورتی که فایل گزارش یا پیام اصلی قابل خواندن نباشد، یک اعلان عدم تحویل ارسال می‌شود. به‌صورت اختیاری، یک کلاینت bounce (یا defer، trace) می‌تواند درخواست کند که در صورت شکست عملیات درخواستی، فایل گزارش پیام حذف شود. این سازوکار توسط کلاینت‌هایی استفاده می‌شود که خودشان نمی‌توانند تراکنش‌ها را مجدداً امتحان کنند و به منطق تلاش مجدد در سمت کلاینت خود متکی هستند. .SH "استانداردها (STANDARDS)" .na .nf RFC 822 (پیام‌های متنی اینترنت ARPA) RFC 2045 (قالب بدنه پیام‌های اینترنتی) RFC 2822 (قالب پیام‌های اینترنتی) RFC 3462 (اعلان‌های وضعیت تحویل) RFC 3464 (اعلان‌های وضعیت تحویل) RFC 3834 (سرآیند پیام Auto\-Submitted:) RFC 5322 (قالب پیام‌های اینترنتی) RFC 6531 (پروتکل SMTP بین‌المللی‌شده) RFC 6532 (قالب پیام بین‌المللی‌شده) RFC 6533 (اعلان‌های وضعیت تحویل بین‌المللی‌شده) .SH "عیب‌یابی (DIAGNOSTICS)" .ad .fi مشکلات و تراکنش‌ها در \fBsyslogd\fR(8) یا \fBpostlogd\fR(8) ثبت می‌شوند. .SH "پارامترهای پیکربندی (CONFIGURATION PARAMETERS)" .na .nf .ad .fi تغییرات اعمال‌شده در \fBmain.cf\fR به‌صورت خودکار اعمال می‌شوند، زیرا فرایندهای \fBbounce\fR(8) تنها برای مدت محدودی اجرا می‌شوند. برای تسریع در اعمال تغییرات، از دستور "\fBpostfix reload\fR" استفاده کنید. متن زیر تنها خلاصه‌ای از پارامترها را ارائه می‌دهد. برای جزئیات بیشتر شامل مثال‌ها، به \fBpostconf\fR(5) مراجعه کنید. .IP "\fB2bounce_notice_recipient (postmaster)\fR" گیرنده نامه‌های غیرقابل‌تحویلی که نمی‌توان آن‌ها را به فرستنده بازگرداند. .IP "\fBbackwards_bounce_logfile_compatibility (yes)\fR" تولید رکوردهای اضافی در فایل گزارش \fBbounce\fR(8) که برای نسخه‌های قبل از 2.0 در Postfix قابل خواندن باشند. .IP "\fBbounce_notice_recipient (postmaster)\fR" گیرنده اعلان‌های مدیر پست (postmaster) حاوی سرآیندهای نامه‌هایی که Postfix تحویل نداده است، و رونوشت روندهای گفتگوی SMTP برای نامه‌هایی که Postfix دریافت نکرده است. .IP "\fBbounce_size_limit (50000)\fR" حداکثر مقدار متن پیام اصلی که در یک اعلان عدم تحویل ارسال می‌شود. .IP "\fBbounce_template_file (empty)\fR" مسیر فایل پیکربندی حاوی الگوهای پیام برگشتی (bounce). .IP "\fBconfig_directory (see 'postconf \-d' output)\fR" محل پیش‌فرض فایل‌های پیکربندی main.cf و master.cf در Postfix. .IP "\fBdaemon_timeout (18000s)\fR" مدت زمانی که یک فرایند دیمن Postfix مجاز است برای رسیدگی به یک درخواست صرف کند، پیش از آنکه توسط تایمر نظارتی داخلی متوقف شود. .IP "\fBdelay_notice_recipient (postmaster)\fR" گیرنده اعلان‌های مدیر پست (postmaster) حاوی سرآیندهای پیام‌هایی که در بازه زمانی تعیین‌شده با $delay_warning_time تحویل داده نشده‌اند. .IP "\fBdeliver_lock_attempts (20)\fR" حداکثر تعداد تلاش‌ها برای به‌دست آوردن قفل انحصاری روی فایل صندوق پستی یا فایل گزارش \fBbounce\fR(8). .IP "\fBdeliver_lock_delay (1s)\fR" فاصله زمانی میان تلاش‌ها برای به‌دست آوردن قفل انحصاری روی فایل صندوق پستی یا فایل گزارش \fBbounce\fR(8). .IP "\fBipc_timeout (3600s)\fR" محدودیت زمانی برای ارسال یا دریافت اطلاعات از طریق یک کانال ارتباطی داخلی. .IP "\fBinternal_mail_filter_classes (empty)\fR" دسته‌هایی از نامه‌های تولیدشده توسط Postfix که مشمول بازرسی محتوا پیش از صف (before\-queue) از طریق non_smtpd_milters، header_checks و body_checks می‌شوند. .IP "\fBmail_name (Postfix)\fR" نام سیستم پستی که در سرآیندهای Received:، بنر خوش‌آمدگویی SMTP و نامه‌های برگشتی نمایش داده می‌شود. .IP "\fBmax_idle (100s)\fR" حداکثر مدت زمانی که یک فرایند دیمن بیکار Postfix پیش از پایان دادن داوطلبانه به کار خود، در انتظار اتصال ورودی می‌ماند. .IP "\fBmax_use (100)\fR" حداکثر تعداد اتصالات ورودی که یک فرایند دیمن Postfix پیش از پایان دادن داوطلبانه به کار خود، به آن‌ها پاسخ می‌دهد. .IP "\fBnotify_classes (resource, software)\fR" فهرست رده‌های خطایی که به مدیر پست (postmaster) گزارش می‌شوند. .IP "\fBprocess_id (read\-only)\fR" شناسه فرایند (PID) یک دستور یا فرایند دیمن Postfix. .IP "\fBprocess_name (read\-only)\fR" نام فرایند یک دستور یا فرایند دیمن Postfix. .IP "\fBqueue_directory (see 'postconf \-d' output)\fR" محل دایرکتوری سطح بالای صف در Postfix. .IP "\fBsyslog_facility (mail)\fR" تسهیلات لاگ (syslog facility) برای سیستم ثبت گزارش Postfix. .IP "\fBsyslog_name (see 'postconf \-d' output)\fR" پیشوندی که در رکوردهای syslog به ابتدای نام فرایند اضافه می‌شود، به طوری که به عنوان مثال "smtpd" به "prefix/smtpd" تبدیل می‌شود. .PP در Postfix نسخه 3.0 و بالاتر موجود است: .IP "\fBsmtputf8_autodetect_classes (sendmail, verify)\fR" تشخیص این که یک پیام برای رده‌های مبدا مشخص‌شده نامه، نیازمند پشتیبانی از SMTPUTF8 است. .PP در Postfix نسخه 3.3 و بالاتر موجود است: .IP "\fBservice_name (read\-only)\fR" نام سرویس یک فرایند دیمن Postfix در master.cf. .PP در Postfix نسخه 3.6 و بالاتر موجود است: .IP "\fBenable_threaded_bounces (no)\fR" فعال‌سازی اعلان‌های عدم تحویل، تحویل موفق و تاخیر به گونه‌ای که با گنجاندن سرآیندهای References: و In\-Reply\-To: همراه با مقدار Message\-ID اصلی، به پیام اولیه متصل و زنجیره‌بندی شوند. .PP در Postfix نسخه 3.7 و بالاتر موجود است: .IP "\fBheader_from_format (standard)\fR" قالب سرآیند \fBFrom:\fR تولیدشده توسط Postfix. .PP در Postfix نسخه 3.10 و بالاتر موجود است: .IP "\fBtls_required_enable (yes)\fR" فعال‌سازی پشتیبانی از سرآیند پیام "TLS\-Required: no" که در RFC 8689 تعریف شده است. .PP در Postfix نسخه 3.11 و بالاتر موجود است: .IP "\fBrequiretls_redact_dsn (yes)\fR" هنگام ارسال اعلان وضعیت تحویل برای پیامی اصلی که با گزینه REQUIRETLS دریافت شده است، بدنه پیام اصلی ارسال نشود (همانند حالتی که پیام با "RET=HDRS" دریافت شده باشد) و الزام REQUIRETLS نیز اعمال نگردد (همانند حالتی که پیام بدون REQUIRETLS دریافت شده باشد). .SH "فایل‌ها (FILES)" .na .nf /var/spool/postfix/bounce/* رکوردهای عدم تحویل /var/spool/postfix/defer/* رکوردهای عدم تحویل /var/spool/postfix/trace/* رکوردهای وضعیت تحویل .SH "همچنین ببینید (SEE ALSO)" .na .nf bounce(5)، قالب الگوی پیام برگشتی (bounce) qmgr(8)، مدیر صف postconf(5)، پارامترهای پیکربندی master(5)، گزینه‌های عمومی دیمن master(8)، مدیر فرایندها postlogd(8)، سیستم ثبت گزارش Postfix syslogd(8)، سیستم ثبت گزارش سیستمی .SH "مجوز (LICENSE)" .na .nf .ad .fi مجوز Secure Mailer باید به همراه این نرم‌افزار توزیع شود. .SH "نویسندگان (AUTHORS)" .na .nf Wietse Venema IBM T.J. Watson Research P.O. Box 704 Yorktown Heights, NY 10598, USA Wietse Venema Google, Inc. 111 8th Avenue New York, NY 10011, USA Wietse Venema porcupine.org