basic_ldap_auth(8) System Manager's Manual basic_ldap_auth(8) (NAME) basic_ldap_auth - LDAP Squid (SYNOPSIS) basic_ldap_auth -b " base DN " [-u attribute ] [ options ] [ LDAP server name [: port ]| URI ]... basic_ldap_auth -b " base DN " -f " LDAP search filter " [ options ] [ LDAP server name [: port ]| URI ]... (DESCRIPTION) basic_ldap_auth Squid HTTP ( Basic) LDAP . LDAP LDAP / (space) . Squid OK ERR LDAP . . DN DN (base DN) . DN DN . (OPTIONS) -b basedn . DN (base DN) . -f filter LDAP ( filter ) DN . DN DN . %s "uid=%s" RFC2037. LDAP RFC2254 . % %s %s (crash ). -u userattr DN / . ( -f ) DN DN . uid . : LDAP . LDAP DN ( -f ). -U passwordattr ldap_simple_bind ldap_compare . passwordattr LDAP . -s base|one|sub DN -f . sub . base () ( one ) ( subtree ) . -D binddn -w password DN (bind) . -f . Squid . Squid . -D binddn -W secretfile DN (bind) . : squid secretfile . -P (persistent) LDAP. LDAP LDAP . LDAP . . -O (bind) LDAP. LDAP ldap_bind . . -P LDAP DN DN . -R (referrals). -a never|always|search|find (dereference aliases). never . never () always search () find () . -H ldap_uri LDAP LDAP URI ( OpenLDAP ). . -h ldap_server LDAP . . -p ldap_port LDAP LDAP TCP . servername:port . -v 2|3 LDAP. 3 . -Z TLS. -S certpath LDAP SSL ( Netscape LDAP API ). -c connect_timeout ( timeout ) LDAP ( Netscape LDAP API ). -t search_timeout LDAP. -d (Debug) . . (CONFIGURATION) RFC2307 DN (base DN) : basic_ldap_auth -b ou=people,dc=your,dc=domain ldapserver (sub- domains) DN DN : basic_ldap_auth -b dc=your,dc=domain -f uid=%s ldapserver : basic_ldap_auth -b dc=your,dc=domain -f (&(uid=%s)(specialattribute=value)) ldapserver DN uid cn Active Directory : basic_ldap_auth -u cn -b cn=Users,dc=your,dc=domain ldapserver DN -D -w DN Active Directory: basic_ldap_auth -P -R -b dc=your,dc=domain -D cn=squid,cn=users,dc=your,dc=domain -w secretsquidpassword -f (&(userPrincipalName=%s)(objectClass=Person)) activedirectoryserver : basic_ldap_auth ldapsearch . . (AUTHOR) Glenn Newton Henrik Nordstrom . Henrik Nordstrom . (COPYRIGHT) * Copyright (C) 1996-2026 The Squid Software Foundation and contributors * * Squid software is distributed under GPLv2+ license and includes * contributions from numerous individuals and organizations. * Please see the COPYING and CONTRIBUTORS files for details. . (GNU GPL) (GPLv2+) . (QUESTIONS) . LDAP LDAP . (REPORTING BUGS) . https://wiki.squid- cache.org/SquidFaq/BugReporting . https://bugs.squid-cache.org/ . . . (SEE ALSO) squid(8), ldapsearch(1), GPL(7), LDAP . RFC2254 - The String Representation of LDAP Search Filters, (Squid FAQ wiki) https://wiki.squid- cache.org/SquidFaq (Squid Configuration Manual) http://www.squid-cache.org/Doc/config/ 14 January 2005 basic_ldap_auth(8)